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1 General Remarks

1.1 Purpose and Scope

This document describes a typical BRAMS station and provides recommendation settings for 
the software and hardware that compose this station.

1.2 Acronyms and Abbreviations

BISA Belgian Institute for Space Aeronomy

BRAMS Belgian Radio Meteor Stations

GPS Global Positioning System

IMO International Meteor Organization

NTP Network Time Protocol

PPS Pulse Per Second

SL Spectrum Laboratory

UTC Coordinated Universal Time

VMO Virtual Meteor Observatory

2 Hardware
The hardware consists of the following components: a Yagi antenna, a ICOM IC-R75 receiver, 
a Garmin 18x GPS, a Beringher UCA222 USB audio interface and a computer. All material, 
except the computer is provided by the Belgian Institute for Space Aeronomy (BISA).

2.1 Personal Computer

The PC shall have Windows XP or further installed on it. The PC shall have at least one free 
USB port to power the GPS.

The ideal  station should come with  a serial  port  (COM) used to connect the GPS to the  
computer for synchronizing the system time.

If your PC is no longer equipped with a serial port, you can consider one of the following 
solutions (in decreasing order of preference).

Solution 1: Even if the computer does not have an external serial port, it might still have an  
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on-board connector. Then it is possible to buy a cheap serial slot bracket to lead it out.

Solution 2: Add a serial card in one of the available PCI slot of your computer.

Solution 3: Use a USB/Serial converter. This solution requires an additional free USB port.  
Some  converters  are  not  suitable  for  this  project.  We  recommend  to  use  the  UC232A 
converter  (http://www.aten.com/products/productItem.php?model_no=UC232A)  from  the 
ATEN company.

Note: be sure that opening your computer case is not part of the warranty-void conditions of 
your PC vendor. It should normally not: you should have the right to add an extension card to 
your PC.

http://www.aten.com/products/productItem.php?model_no=UC232A
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2.2 Antenna

The antenna is a 3-element Yagi with adjustable inclination. The elevation of the antenna is 
chosen to point it toward a point approximately 100 km above the radio beacon in Dourbes 
(50.80° North & 4.43° East). The azimuth of the antenna is the direction of the beacon.

The antenna is connected to the receiver with a coaxial cable of type RG213.

2.3 Receiver

The receiver is a commercial  radio receiver,  type ICOM R-75. The automatic gain control 
(AGC) must be switched off.

For those not familiar with this receiver, here are a few hints on how to use it for BRAMS 
observations:

• Connect the RG213 cable to [ANT1] connector.

• Antenna selection: Push [ANT(SET)] for 2 seconds to select ANT1. “ANT1” appears on 
the screen when the [ANT1] connector is in use.

• Frequency selection: Enter 49.969 MHz for the frequency. Push the numerical keys on 
the keypad to enter the MHz digits (49). Push [.] on the keypad. Push the numerical 
keys  to  enter  the  frequency  digits  below  1  Mhz  (969).  Push  [ENT].  If  a  key  is  
mistakenly pushed, push [CLR] and start again from the beginning.

• Mode selection: Push [SSB] to toggle between LSB and USB. Choose USB.

• Automatic Gain Control: Push [AGC] for 2 seconds to turn the AGC circuit OFF. “AGC 
OFF” appears on the screen when the AGC circuit is turned off.

• Preamplification: Push [P.AMP] to toggle between pre-amp1 and pre-amp2. Choose 
pre-amp2 which has the largest gain. “PREAMP2” appears on the screen while pre-
amp2 is activated.

• Dial Lock function: this function prevents accidental changes and electronically locks 
the dial. Push [LOCK] momentarily to ON. “LOCK” appears in the screen when the lock 
function is activated.

Below is a picture of the screen of the ICOM-R75 when in use at the Uccle station.
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The  REC  OUT output  of  the  receiver  is  connected  to  the  left  channel  (white  or  black 
connector) of the line-in entry (light blue) of the PC using a RCA/Jack adapter (See figure 
below). The right channel (red connector) is used for the GPS.

2.4 Garmin GPS 18x LVC Sensor

2.4.1 Description

The  Garmin  18x  LVC  is  a  serial  GPS  with  one-pulse-per-second  (PPS)  output1. 
The rising edge of the PPS is aligned to the start of each GPS second within 1 μs for all  
conditions in which the receiver has reported a valid and accurate position for at least the 
previous 4 seconds.

1 Only serial devices provide the very accurate Pulse Per Second (PPS) output.
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2.4.2 Installation

The GPS shall ideally be installed outside, at a location with a clear view of the sky. If it is not  
possible to locate the GPS outside, try to install it next to a large window.

The GPS must be powered by one of the USB ports of the PC. Plug the DE9 connector into 
the serial port (or USB/Serial converter) and the RCA connector into the right channel of the 
line-in entry of the sound card.

It is possible that Windows incorrectly interprets the output of the GPS as the output of a  
Microsoft Serial Ballpoint mouse. When that happens, Windows loads drivers for the Serial  
Ballpoint Mouse. This causes the cursor to move erratically across the display, clicking when 
moving.

The easiest solution to solve this problem is to disable the Serial  BallPoint mouse in the 
device Manager. When erratic mouse movements occur, follow the steps below.

1. Unplug the DE9 connector.

2. Right-click on the  My Computer icon on your desktop and select  Properties to open 
Device Manager.

3. Go  to  the  hardware  tab  of  the  resulting  pop-up  window and  click  on  the  Device 
Manager button.

4. Right-click on Serial Ballpoint Mouse and choose the option to Disable (not Uninstall) 
this device.

2.4.3 Configuration

In order to send the PPS and the NMEA data to the same line input, the two signals must not 
overlap in time. To fulfill this requirement some of the NMEA sentences sent by the GPS must 
be disabled. This can be achieved with Garmin's configuration software.

Note  that  you  should  have  received  the  GPS  already 
configured. This section has been added for completeness only.



BRAMS Station Manual

Date:
Page:

 2/20/15
 8

The Garmin Sensor Configuration Software (SNSRCFG.exe) is available from the Garmin 
Web site. To download the software, start at http://www.garmin.com/oem, select the GPS 18x, 
and then click on  Software in the  Quick Links menu. If  you experiment troubles with new 
versions, there is an old one at http://brams.aeronomie.be/files/SNSRXCFG_2.60.exe.

After the software is installed and running on your computer, follow the steps below to disable  
NMEA sentences:

1. Select the GPS 18x PC/LVC from the list of sensors and Click OK.

2. Select Comm > Setup to open the Comm Setup Window.

3. Select the serial port to which the GPS is connected. Select  Auto to let the program 
automatically determine the baud rate, or select  Manual to manually select the baud 
rate of the GPS. Click OK when done. 

4. Click the Connect icon, or select Comm > Connect to connect to the GPS. 

5. Select Config > Get Configuration from GPS to retrieve the current programming of the 
GPS.

6. Select  Config >  Sensor Configuration.  In  the  System Configuration panel,  enter an 
identification string (BISA inventory number for instance) in the Device ID field to avoid 
a bug in the configuration software.

7. Select  Config >  NMEA Sentence Selections.  Uncheck all  NMEA sentences,  expect 
GPGGA and GPRMC. Click OK when done.

8. Select Config > Send Configuration to GPS to send the new programming to the GPS.

2.5 BERINGHER U-CONTROL UCA222

Beringher UCA222 is an USB audio interface with two RCA inputs. It gets its power from your 
computer's USB bus, so no external power supply or batteries are required. The UCA222 
requires  no  special  setup  or  drivers,  just  plug  it  into  a  free  USB port  and  it  should  be  
automatically recognized by Windows.

http://brams.aeronomie.be/files/SNSRXCFG_2.60.exe
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Connect the receiver to the left RCA input of the audio interface with the help of the RCA-RCA 
cable and the Jack/RCA adapter provided by BISA. Connect the GPS to the right RCA input.

Install the USB audio driver corresponding to your operating system:

1. Download the driver that corresponds to your operating system.  For 32-bit Windows 
http://brams.aeronomie.be/files/BEHRINGER_2902_WIN32_2.8.40.zip For  64-bit 
Windows http://brams.aeronomie.be/files/BEHRINGER_2902_X64_2.8.40.zip

2. Right-click on the downloaded file and select Extract All...  This will open a dialog box 
asking you where you want to extract the files.

3. Keep the default location ...\Desktop\BEHRINGER_2903_X64_2.8.40 and click on the 
Extract button.

4. Go to  ...\Desktop\BEHRINGER_2903_X64_2.8.40\BEHRINGER_2903_X64_2.8.40.  If 
you are logged in with administrator privileges, double-click on the Setup.exe program. 
If you are logged in as a normal user, right-click on the Setup.exe program and select 
Run as administrator to start installing the driver.

5. Select  your  preferred  language  and  click  on  Install  the  driver.  The  program  will 
eventually ask you to plug the USB sound card if it is not already connected to your 
PC.

6. Once the installation finished, the program will ask you to reboot your computer.

This will install both the Windows Driver Model (WDM) and Audio Stream Input/Output (ASIO) 
drivers.

http://brams.aeronomie.be/files/BEHRINGER_2902_X64_2.8.40.zip
http://brams.aeronomie.be/files/BEHRINGER_2902_WIN32_2.8.40.zip
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3 Software
We use Spectrum Lab (SL) to record the radio signal. SL runs under Windows XP, Vista, 
Windows 7 and Linux/WINE (not tested).

3.1 Windows

Windows XP needs 512 MB RAM to work properly. More recent Operating Systems need 
even more memory.

• It is strongly advised to dedicate the PC to this specific task to avoid disturbing the 
real-time capture of the radio samples.

• Install the latest Service Pack and all relevant updates.
• Configure Windows Update to download updates only manually.
• Stop unnecessary programs. Press the "Control," "Alt," and "Delete" keys at the same 

time. Select "Task Manager" from the screen that comes up. Click on the "Applications" 
tab. Choose running programs that you are not using and click the "End Task" button. 
Close all running programs that you are not using.

• Disable  startup  programs.  Click  "Start"  and  choose  "Run."  Enter  the  command 
"msconfig" without quotes. Select the "Startup" tab. Uncheck the boxes next to any 
program you don't want to run at startup.

• Ensure that your computer is free of malware (spyware, viruses, …).

3.1.1 Time Zone Configuration

SL uses the local time of your PC to create timestamps. Using the Timezone, Clock source,  
Timer calibration settings of SL, it is possible to adjust the local time, but this probably does 
not take daylight saving time into account.

So the only possibility is to set your Windows system clock to UTC. Do not forget to do this 
before starting the recording otherwise some of your data files might be overwritten.

1. Open Date & Time in Control Panel.

2. To change your time zone, click on the Time Zone tab. In the box above the map, click 
the drop-down arrow, and then click on (GMT) Coordinated Universal Time. With some 
versions of Windows this option may not be available. Use then (GMT) Casablanca 
instead.

3. Click OK when done.
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3.2 Meinberg NTP

NTP (Network Time Protocol) is a background process which synchronizes the system time of 
the computer to one or more external reference time sources which can be either another 
computer on the network, or a GPS clock which is connected locally to the computer.

The official public domain NTP application does not support Windows operating systems, but 
Meinberg, a company specialized in time synchronization, provides a Windows package built  
from the original sources.

The Meinberg  package can be downloaded at  http://www.meinberg.de/english/sw/ntp.htm. 
The latest version is 4.2.4p8 and runs on Windows NT, 2000, XP, 2003/2008 Server, Vista 
and Windows 7 (either 32-bit or 64-bit version). Older versions are not supported because of  
missing features in the Windows kernel.

Note that other time synchronization programs (e.g. Dimension 
4) do not work with the GPS. Therefore you MUST install the 
Meinberg package.

NTP installation is straightforward:  just  keep the default  settings.  When it  will  ask you to 
specify  your  configuration  settings,  enter  the  address  of  the  official  Belgian  time  server 

http://www.meinberg.de/english/sw/ntp.htm
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(ntp.oma.be), which is hosted by the Royal Observatory of Belgium (ROB).

After  NTP  is  installed  and  running  on  your  computer,  you  have  to  replace  its  default 
configuration file by the one we have pre-configured to use the Garmin GPS as primary time 
source:

1. Go to  Start > Programs > Meinberg > Network Time Protocol > Service Control  and 
click on  Stop NTP Service to close the NTP service.  Note that, on Windows 7, you 
have to right-click on the menu entry  and select Run as administrator even if you are 
logged in as a user with administrator privileges.

2. Download the ntp.conf file from http://brams.aeronomie.be/files/ntp.conf and copy it to 
C:\Program Files\NTP\etc\ntp.conf. If Windows 7 prevents you to replace this file even 
logged in as administrator, follow this procedure to bypass the problem:

◦ Open  the  http://brams.aeronomie.be/files/ntp.conf link  in  your  browser 
and copy the content to the clipboard.

◦ Open the  Notepad editor with administrator privileges: go to  Start > All  
Programs > Accessories, then right-click on the Notepad entry and select 
Run as administrator.

◦ Open the file C:\Program Files\NTP\etc\ntp.conf.

◦ Select all (Ctrl+A) the file, replace it by the contents of the clipboard (Ctrl-

http://brams.aeronomie.be/files/ntp.conf
http://brams.aeronomie.be/files/ntp.conf
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V) and save it.

3. Review the configuration by selecting Start > Programs > Meinberg > Network Time 
Protocol > Edit NTP Configuration.

4. If you do not have a permanent Internet connection, comment the lines corresponding 
to the time servers with the sharp (#) character:

# Pick up some random servers in neighbouring pools.
# server 0.be.pool.ntp.org iburst
# server 1.be.pool.ntp.org iburst
# server 1.fr.pool.ntp.org iburst
# server 2.fr.pool.ntp.org iburst
# server 1.nl.pool.ntp.org iburst
# server 2.nl.pool.ntp.org iburst

# Use specific NTP servers
# server ntp.oma.be iburst

5. If the GPS is not connected to the first serial port, replace 1 by the number of the right 
port in the following line:

server 127.127.20.1 mode 0 iburst minpoll 4 maxpoll 6 prefer 

For instance, 127.127.20.4 corresponds to a serial GPS connected to COM4.

6. Save the configuration file and restart the NTP service by selecting Start > Programs > 
Meinberg > Network Time Protocol > Service Control > Start NTP Service.  Note that, 
on  Windows  7,  you  have  to  right-click  on  the  menu  entry   and  select  Run  as 
administrator even if you are logged in as a user with administrator privileges.

To check that NTP runs correctly, wait a few minutes and go to Start > Programs > Meinberg  
> Network Time Protocol and select NTP Quick Status. You should see a command window 
that looks like the one below.
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Look at the line corresponding to the GPS. The reach value should be 377. If it has not yet 
reached this value, wait a few more minutes and check again. You should see a star (*) at the 
beginning of this line, which means that the GPS has been selected as the primary time 
source. The offset should be a few milliseconds (Note that values in the offset column are 
expressed in milliseconds) and the  when value should never become greater than the  poll 
one.

3.3 Spectrum Lab

Spectrum Lab started as a simple FFT program running under DOS a long time ago, but it is  
now a specialized audio analyzer, filter, frequency converter, hum filter, data logger, etc.

Please use version 2.76b26 available on the BRAMS website,  so everybody will  use the 
same  version  (http://brams.aeronomie.be/files/speclab_v2.76b26.zip).  Even  though  it  is  a 
beta version, it is stable. If  you already have an old version installed on your PC, please 
consider upgrading to this version.

At  http://brams.aeronomie.be/files/SETTINGS.INI,  you  will  find  a  standardized  setting  file. 
This file shall be stored in the installation directory of SL (by default C:\Spectrum).

http://brams.aeronomie.be/files/SETTINGS.INI
http://brams.aeronomie.be/files/speclab_v2.76b26.zip
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3.3.1 Directory Settings

The default  location for storing WAV files is  C:\Data\WAV,  the default  location for storing 
images is C:\Data\JPG. You might also choose another location (the procedure is explained 
below) depending on the free storage of your local disks. One day of recording represents  
one gigabyte of data and it would be good to have free space for a few months.

Note that you have to manually create the  C:\Data\WAV  and 
C:\Data\JPG directories. Otherwise the files will not be stored.

To prevent those directories from being overwhelmed by the huge amount of files (8640 per 
month typically), the setting file has been pre-configured to save data files in year\month\day 
subdirectories below the C:\Data\WAV and C:\Data\JPG locations.

To create this hierarchy of subdirectories, follow the steps below:

1. Download the file available at http://brams.aeronomie.be/files/2011_2015.exe.

2. Double-click on the file, click on the 3-dot button and go to the C:\Data\WAV directory. 
Then click on the OK button.

3. Click on the Extract button to create the subdirectories. This operation can take several 
minutes depending of the power of your PC.

4. Repeat the procedure for the C:\Data\JPG directory.

Do not forget to unzip the archive for both C:\Data\WAV and 
C:\Data\JPG directories.

This will create the year\month\day structure up to year 2015. Of course, you are free to use 
your own data organization, but do not forget to modify the setting file according to your  
preferences.

http://brams.aeronomie.be/files/2011_2015.exe
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3.3.2 System Settings

3.3.2.1 Audio Settings

The audio interface to use with SL is stored in the MCONFIG.INI file which is specific to each 
installation. So you must manually select the UCA222 interface as input device:

1. Select Audio settings, I/O device selection in the Options Menu.

2. Select  USB Audio CODEC or  Line In (BEHRINGER USB WDM Audio 2.8.40) in the 
Audio Input Device combo box. Always select the Windows Driver Model (WDM) and 
not the ASIO driver (BEHRINGER USB AUDIO).

3. Click on Apply button.

Note that it is still possible to listen to the meteor echoes using the internal audio card of the  
PC as output device; but since the GPS signal is recorded in stereo, it is advised to push the 
audio balance to  the left.  The other solution is to connect  external  speakers to the USB 
interface.

3.3.2.2 GPS Settings

Open the  Options  and  select  GPS receiver.  Then  click  on  the  Configuration tab.  Chose 
Soundcard for the GPS port and 4800 for the GPS speed. Check use GPS time, no local and 
then click on the Apply button.
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3.3.3 Data Settings

The important parameters in this file are:

• Stereo recording of the radio signal and the GPS signal.

• Continuous calibration of the sample rate of the audio card, using the PPS from the 
GPS.

• A sampling rate of 22050 Hz, 16 bit per sample.

• A new WAV file is started every five minutes.

• A JPG image of the spectrogram is captured every five minutes.

• Images are tagged with the frequency of the beacon and the time of capture.

By default, the setting file is configured for Uccle's station. You must substitute this with your 
own location:

1. Select Periodic Actions... in the File menu.

2. Substitute the value of the location variable with the VMO code of your location (see 
appendix).

3. Click on the Test button to check your syntax, then on Apply and OK.
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Note that you can change the default location where the data are stored by changing  the 
value of the root variable.

It is very important that you keep all other default data settings 
(sample rate, bit depth, etc) and the naming convention of the 
WAV files.

3.3.4 Visual Settings

The visual preferences that come with the setting file are:

• The spectrum graph and spectrogram (waterfall) are displayed from 500Hz to 1500Hz.

• The color palette is  sunrise. The brightness is set to about 40% and the contrast to 
about 75%.
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• The amplitude range of the signal displayed goes from -120db to 0dB.

• The option Vertical Frequency Axis  is checked, so the spectrogram (waterfall) scrolls 
from right to left with a horizontal time axis and a vertical frequency axis.

By default, the displayed part of the spectrum graph and spectrogram goes from 500Hz to  
1500Hz.  This  has  to  be  reduced  to  an  interval  of  e.g.  200Hz  centered  on  the  carrier 
frequency. To do so, change the values of the  Min and  Max  fields in the frequency control 
panel.

To add your specific location on the spectrograms generated every five minutes:

1. Select Screen capture options in the Options menu.

2. Replace BEUCCL by the VMO code of your location (see appendix) in the second line.

3. Click on the Update preview button to check that the capture looks fine, then on OK.

We  suggest  you  to  keep  other  parameters  unchanged  to  ease  the  comparison  of 
spectrograms issued from different stations.

3.3.5 Check SL Functioning

To be sure that SL keeps the modified settings, close it and open it again. This will force SL to  
write the current configuration in its setting file.

3.3.5.1 Check SL components

Open the Components menu and select Show Components (circuit window). All the SR cal, 
ADC, DAC and Spectrum Analyser1 components should be colored in green.
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3.3.5.2 Check Time Source

Open  the  Options menu  and  select  System  settings  >  Timezone,  time  source,  timer  
configuration. The primary time source should be Use audio-sampling clock.
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3.3.5.3 Check Signal Amplitude

Open the Components menu and select the Input Monitor component. The signal can turn red 
for brief periods but should be green most of the time.

If the signal color is mostly red, decrease the audio gain of the line-in entry in the volume 
control panel of Windows.

3.3.5.4 Check Sample Rate Calibration

Open the  Components  menu and select the  Sampling Rate Detector (to compensate ADC  
clock drift) component.
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The color of the Status line at the bottom of the dialog box should be green.

3.3.5.5 Check GPS Position

Open the Options menu and select GPS receiver.

The dialog box should display the current  GPS position and UTC time. High accuracy is 
achieved when the number of satellites is close to twelve and the HDOP value is close to one.

3.3.5.6 Check File Recording

Wait for the next five minutes frontier and check that SL creates the WAV and JPEG files in 
the corresponding directory.

3.3.6 File Naming Convention

The naming of files is based on the convention used in the Virtual Meteor Observatory (VMO). 

Geographic locations are identified by the  two-letter country code (BE – Belgium), followed 
by the first four letters of the location (UCCL – Uccle). In case of conflicts, the last letter of the 
code is replaced by the last letter of the location name. If a conflict remains, the last letter of  
the code is replaced by a number starting from 2.

The type of data is also standardized by the VMO:

• CAM is for camera observations (video or still).

• FIR is for fireball observations.

• ORB is for meteoroid orbits and trajectories.

• RAD is for radio observations.

• VIS is for visual observations.

Hereafter an example of the naming convention used in the BRAMS archive:
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RAD_BEDOUR_20110505_0800_BEUCCL_SYS001.wav

This file represents data from the Dourbes beacon, recorded at 8h00 UT on May 5th 2011 by 
the first antenna of the Uccle station.

The significant parts of the file are separated by underscores:

• RAD: file contains radio data.

• BEDOUR: location of the beacon. If several beacons exist at the place, duplicate rules 
of VMO are used to distinguish the beacon.

• 20110505: date of recording.

• 0800: start time of recording.

• BEUCCL: location of the station. If several stations exist at the same place, duplicate 
rules of VMO are applied.

• SYS001: code of  the recording system. Most  stations have only one antenna,  but  
some  have  several  antennas.  (for  instance,  Uccle  has  two  antennas  and  the 
interferometer at Humain has five antennas).

3.4 BRAMS Decoder

The BRAMS Decoder is a console application that decodes the GPS channel of the WAV files 
and resamples the radio signal from 22050Hz to 5512Hz. It also adds some metadata such 
as the station code or the calibrated sample rate to the file. The process is illustrated in the  
following picture.
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The purpose is to reduce the size of the files (from 26MB to 3MB) while keeping precise 
information about the timestamping of the data.

The application runs every day at 2am and processes the files of the day before.

3.4.1 Installation

The BRAMS decoder can be downloaded at http://brams.aeronomie.be/files/brams-decoder-
1.1-setup.exe. This package has been tested on the Windows XP SP3 and Windows 7 (32-
bit).  The installation is straightforward: the program asks you a few questions about  your 
settings and create a scheduled task to run the decoding every day at 2am.

In case the scheduled task is not automatically created by the installer, here is the procedure 
to create it manually.

On Windows XP:

1. Open Scheduled Tasks in Control Panel.

2. Double-click on Add Scheduled Task and then click on Next.

3. Windows asks you the program you want to run. Click Browse and select C:\Program 
Files\BRAMS  Decoder\bin\brams-decoder.bat.  If  you  see  two  brams-decoder files 
without  extensions  in  the list,  choose the first  one.  The reason is  that,  by default, 
Windows hides extensions for file types such as bat or exe2.

4. Select Perform this task Daily, then click Next.

5. Select 2:00 as starting time and the current day as starting date.

6. Windows asks you the name of the user that will run the task. Enter SYSTEM in the 
user name field and leave the password fields empty.

7. Check Open advanced properties for this task when I click Finish and then click Finish.

8. Go to the Settings tab and uncheck the two options in the Power Management section.

9. Click OK to finalize the creation.

On Windows 7:

1. In  the  Control  Panel,  click  on  Administrative  Tools,  then  double-click  on  Task 
Scheduler.

2. In the Action menu, select Create Task....

2 If like me you do not like this feature, It is possible to deactivate it in your Windows explorer:
1. Open the Tools menu and select Folder Options...
2. Then go to the View tab and uncheck Hide extensions for known file types in the advanced 

settings.
3. Then click Ok.

http://brams.aeronomie.be/files/brams-decoder-1.1-setup.exe
http://brams.aeronomie.be/files/brams-decoder-1.1-setup.exe
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3. In the General tab, enter brams-decoder in the Name field. Click on Change User or  
Group... and enter SYSTEM in the object name field, then click on Check Names to be 
sure the name you entered is correct. Click OK when finish.

4. In the Triggers tab, click on New..., select Daily and 2:00 as starting time. Then click 
OK.

5. In  the  Actions tab,  click  on  New...  and  then  on  Browse....  Select  C:\Program 
Files\BRAMS  Decoder\bin\brams-decoder.bat.  If  you  see  two  brams-decoder files 
without  extensions  in  the list,  choose the first  one.  The reason is  that,  by default, 
Windows hides extensions for file types such as bat or exe3. Click OK when finish.

6. In the Conditions tab, uncheck Start the task only if the computer is on AC power.

7. Click OK to finalize the creation.

3.4.2 Uninstallation

To  remove  the  program,  run  the  uninstaller  located  at  C:\Program  Files\BRAMS 
Decoder\uninstaller.exe.

3.4.3 Configuration File

The  configuration  file  of  the  BRAMS  Decoder  is  located  at  $APPDATA\Brams 
Decoder\etc\brams_decoder.conf,  where  $APPDATA is  C:\Documents  and  Settings\All  
Users\Application Data on Windows XP or  C:\ProgramData on Windows 7. Note that those 
directories are hidden by default.

The configuration file contains a list of parameters. Each parameter has a name and a value, 
delimited  by  an  equals  sign  (=).  Semicolons  (;)  at  the  beginning  of  the  file  indicates  a 
comment. Comment and blank lines are ignored.

Default settings are usually just fine, but here is the list of parameters that you can modify.

Name Description Default Value Mandatory

antenna_id Id of the antenna in case the setup has 
several antennas.

1

beacon Code of the beacon. BEDOUR

beacon_frequency Frequency of the beacon in Hertz. 49970000

3 If like me you do not like this feature, It is possible to deactivate it in your Windows explorer:
4. Open the Organize menu and select Folder and search options.
5. Then go to the View tab and uncheck Hide extensions for known file types in the advanced 

settings.
6. Then click Ok.
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bit_rate Number of bits per second of the GPS 
signal.

4800

decimation_factor Ratio  between  the  old  and  new 
frequencies when resampling.

4

data_directory Root directory where the WAV files are 
stored.

Yes

destination_directory Root directory where the WAV files are 
moved once decoded.

email_log If one, send decoder log by email. See 
SMTP parameters.

0

gps_channel Id of the channel with the GPS signal to 
decode.

2

lo_frequency Frequency of the local oscillator in Hertz. 49969000

lock_file Path  to  lock  file  to  prevent  multiple 
instances for running simultaneously.

Yes

log_directory Directory where the log files are located. Yes

mail_recipient Decoder  log  will  be  sent  to  this  email 
address.

mail_sender Email  address  used  for  sending  the 
decoder log.

nmea_delta Minimum  level  for  NMEA  transitions. 
Between zero and one.

0.2

pps_delta Minimum  level  for  PPS  transitions. 
Between zero and one.

0.4

pps_duration PPS duration in seconds. 0.1

station Code of the station. BEUCCL

smtp_password Password  of  the  SMTP  account  for 
sending decoder log by email.

smtp_server Address  of  the  SMTP  server  where 
sending  the  decoder  log.  The  address 
must begin with 'smtp://' or 'smtps://'. By 
default,  it  connects  to  port  25,  but 
another  port  can  be  specified  with  the 
following  syntax: 
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smtp://mail.example.net:587.

smtp_tls If  one,  issue the  STARTTLS command 
when connecting to the SMTP server.

0

smtp_username Username  of  the  SMTP  account  for 
sending decoder log by email.

timestamp Starting  day  from  which  the  decoding 
must  start.  This  parameter  is  updated 
every time the decoder runs.

Yes

3.4.4 Log File

Some diagnostic information about the decoding process can be found in the log file of the 
BRAMS Decoder. This file is located at $APPDATA\BRAMS Decoder\log\brams_decoder.log, 
where $APPDATA has the same definition than above.

4 References
• BRAMS – Belgian RAdio Meteor Stations

http://brams.aeronomie.be

• GPS 18x Technical Specifications

http://www.garmin.com/manuals/GPS18x_TechnicalSpecifications.pdf

• Meinberg NTP Package

http://www.meinberg.de/english/sw/ntp.htm#ntp_nt_stable

• Spectrum Laboratory

http://www.qsl.net/dl4yhf/spectra1.html

• U-CONTROL UCA222

http://www.behringer.com/EN/Products/UCA222.aspx

• Virtual Meteor Observatory

http://vmo.imo.net/

Appendix A: VMO Codes of the BRAMS Stations

Corbais BECORB

http://vmo.imo.net/
http://www.behringer.com/EN/Products/UCA222.aspx
http://www.qsl.net/dl4yhf/spectra1.html
http://www.meinberg.de/english/sw/ntp.htm#ntp_nt_stable
http://www.garmin.com/manuals/GPS18x_TechnicalSpecifications.pdf
http://brams.aeronomie.be/
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Dinant BEDINA

Genk BEGENK

Geraardsbergen BEGERA

Grimbergen BEGRIM

Harelbeke BEHARE

Hove BEHOVE

Humain BEHUMA

Humbeek BEHUMB

Jalhay BEJALH

Kampenhout BEKAMP

Kapelle-op-den-bos BEKAPE

Langemak BELANG

Lembeek BELEMB

Leuze BELEUZ

Liège BELIEG

Mons BEMONS

Neufchâteau BENEUF

Ophain BEOPHA

Ottignies BEOTTI

Overpelt BEOVER

Redu BEREDU

Seneffe BESENE

Tessenderlo BETESS

Tintigny BETINT

Uccle BEUCCL
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